PE Loader и TLS

Тема в разделе "WASM.WIN32", создана пользователем jeer0, 8 дек 2017.

  1. Indy_

    Indy_ Well-Known Member

    Публикаций:
    4
    Регистрация:
    29 апр 2011
    Сообщения:
    2.160
    superakira,

    Зря вы так думаете, это всё решается элементарно. Вы просто не знакомы с нужными средствами, их достаточно. Во первых это разрабы для себя сделали :)
     
  2. superakira

    superakira Active Member

    Публикаций:
    0
    Регистрация:
    2 июн 2008
    Сообщения:
    391
    Indy_, я знаю, что это не решается элементарно. именно от такого погружения я и хотел избавится. временно я решил проблему, но по уму чтобы было надо разбираться.
     
  3. Indy_

    Indy_ Well-Known Member

    Публикаций:
    4
    Регистрация:
    29 апр 2011
    Сообщения:
    2.160
    superakira,

    В лог идёт полная инфа по загрузке. Вы вообще этот лог видели ?

    А как по вашему резолвятся такие проблемы.. - полистал лог и всё ясно. Вы сами усложняете всё, впрочем это ваше дело, вам решение дано. Во втором случае вы могли привести лог по ошибкам, но вы ничего этого не сделали. Просто тупо тратите своё и моё время, обсуждая не ясно что. Можно просто отладчиком за пять минут посмотреть.
     
  4. superakira

    superakira Active Member

    Публикаций:
    0
    Регистрация:
    2 июн 2008
    Сообщения:
    391
    Всплыли еще моменты по такой технике. А именно на 8.1+ (в основном 10). При создании рпц сервера через RpcServerRegisterIf3 с флажком RPC_IF_AUTOLISTEN валится на ответе клиенту в недрах рпц длл. Хотя при штатной загрузке норм. Настроил работу без этого флага, но вот забавный момент. Это 8.1+. Разрядность любая.

    Делаю заметку, чтобы не забыть.

    Далее - эту технику ловит eshim в верификации модуля и валится через фастфэйл (обходится естественно, но вот такой момент тоже есть).